BETA

27th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [27/03/19 03:13 PM] with 'Partial Outage'

Issue has been resolved at [27/03/19 03:15 PM]