BETA

1st October 2016

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [01/10/16 02:40 AM] with 'Partial Outage'

Issue has been resolved at [01/10/16 03:35 AM]