BETA

7th December 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [07/12/17 04:16 PM] with 'Major Outage'

Issue has been resolved at [07/12/17 04:17 PM]