BETA

7th December 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [07/12/17 04:15 PM] with 'Major Outage'

Issue has been resolved at [07/12/17 04:17 PM]