BETA

1st October 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [01/10/16 02:35 AM] with 'Partial Outage'

Issue has been resolved at [01/10/16 09:44 AM]