BETA

26th March 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [26/03/19 04:11 PM] with 'Partial Outage'

Issue has been resolved at [26/03/19 04:15 PM]