BETA

26th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [26/03/19 03:25 PM] with 'Partial Outage'

Issue has been resolved at [26/03/19 03:29 PM]