BETA

7th December 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [07/12/17 03:47 PM] with 'Partial Outage'

Issue has been resolved at [07/12/17 04:33 PM]