BETA

7th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [07/12/17 03:43 PM] with 'Major Outage'

Issue has been resolved at [07/12/17 03:44 PM]