BETA

7th December 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [07/12/17 01:14 PM] with 'Major Outage'

Issue has been resolved at [07/12/17 01:44 PM]