BETA

26th March 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [26/03/19 05:36 AM] with 'Partial Outage'

Issue has been resolved at [26/03/19 05:39 AM]