BETA

25th March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [25/03/19 09:12 PM] with 'Partial Outage'

Issue has been resolved at [25/03/19 09:14 PM]