BETA

6th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [06/12/17 01:22 PM] with 'Partial Outage'

Issue has been resolved at [06/12/17 01:23 PM]