BETA

6th December 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [06/12/17 01:16 PM] with 'Partial Outage'

Issue has been resolved at [06/12/17 01:37 PM]