BETA

6th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [06/12/17 01:09 PM] with 'Major Outage'

Issue has been resolved at [06/12/17 01:10 PM]