BETA

24th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [24/03/19 08:47 PM] with 'Partial Outage'

Issue has been resolved at [24/03/19 08:48 PM]