BETA

24th March 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [24/03/19 01:45 PM] with 'Partial Outage'

Issue has been resolved at [24/03/19 01:47 PM]