BETA

23rd March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [23/03/19 08:49 PM] with 'Partial Outage'

Issue has been resolved at [23/03/19 08:51 PM]