BETA

23rd March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [23/03/19 12:23 PM] with 'Partial Outage'

Issue has been resolved at [23/03/19 12:24 PM]