BETA

22nd March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/03/19 05:11 PM] with 'Major Outage'

Issue has been resolved at [22/03/19 05:14 PM]