BETA

22nd March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [22/03/19 05:08 PM] with 'Partial Outage'

Issue has been resolved at [22/03/19 05:15 PM]