BETA

2nd December 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [02/12/17 03:17 PM] with 'Major Outage'

Issue has been resolved at [02/12/17 03:18 PM]