BETA

13th March 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [13/03/19 05:45 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/03/19 05:47 AM]