BETA

2nd December 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [02/12/17 07:17 AM] with 'Major Outage'

Issue has been resolved at [02/12/17 08:06 AM]