BETA

22nd March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/03/19 03:05 PM] with 'Partial Outage'

Issue has been resolved at [22/03/19 03:11 PM]