BETA

29th November 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [29/11/17 11:22 AM] with 'Partial Outage'

Issue has been resolved at [29/11/17 11:25 AM]