BETA

28th November 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [28/11/17 01:28 PM] with 'Partial Outage'

Issue has been resolved at [28/11/17 01:29 PM]