BETA

22nd March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [22/03/19 01:44 PM] with 'Major Outage'

Issue has been resolved at [22/03/19 01:51 PM]