BETA

28th November 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [28/11/17 12:51 PM] with 'Partial Outage'

Issue has been resolved at [28/11/17 12:52 PM]