BETA

25th November 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [25/11/17 12:08 PM] with 'Major Outage'

Issue has been resolved at [25/11/17 12:09 PM]