BETA

25th November 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [25/11/17 12:07 PM] with 'Partial Outage'

Issue has been resolved at [25/11/17 12:08 PM]