BETA

22nd March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [22/03/19 01:27 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [22/03/19 01:45 PM]