BETA

25th November 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [25/11/17 08:34 AM] with 'Major Outage'

Issue has been resolved at [25/11/17 08:35 AM]