BETA

22nd March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [22/03/19 01:21 PM] with 'Partial Outage'

Issue has been resolved at [22/03/19 01:23 PM]