BETA

24th November 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [24/11/17 03:58 PM] with 'Major Outage'

Issue has been resolved at [24/11/17 04:07 PM]