BETA

24th November 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [24/11/17 12:12 AM] with 'Major Outage'

Issue has been resolved at [24/11/17 12:13 AM]