BETA

23rd November 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [23/11/17 01:14 AM] with 'Major Outage'

Issue has been resolved at [23/11/17 01:15 AM]