BETA

22nd November 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [22/11/17 02:38 PM] with 'Major Outage'

Issue has been resolved at [22/11/17 02:41 PM]