BETA

22nd November 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/11/17 12:11 AM] with 'Major Outage'

Issue has been resolved at [22/11/17 12:12 AM]