BETA

22nd November 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/11/17 12:10 AM] with 'Major Outage'

Issue has been resolved at [22/11/17 12:12 AM]