BETA

21st November 2017

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [21/11/17 02:12 PM] with 'Major Outage'

Issue has been resolved at [21/11/17 02:21 PM]