BETA

21st November 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [21/11/17 12:16 AM] with 'Major Outage'

Issue has been resolved at [21/11/17 12:17 AM]