BETA

21st November 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [21/11/17 12:15 AM] with 'Major Outage'

Issue has been resolved at [21/11/17 12:17 AM]