BETA

22nd March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [22/03/19 11:05 AM] with 'Partial Outage'

Issue has been resolved at [22/03/19 11:06 AM]