BETA

16th November 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [16/11/17 03:02 AM] with 'Partial Outage'

Issue has been resolved at [16/11/17 03:03 AM]