BETA

13th November 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [13/11/17 03:11 PM] with 'Major Outage'

Issue has been resolved at [13/11/17 03:13 PM]