BETA

13th November 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [13/11/17 02:30 PM] with 'Partial Outage'

Issue has been resolved at [13/11/17 02:31 PM]