BETA

13th November 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [13/11/17 02:23 PM] with 'Major Outage'

Issue has been resolved at [13/11/17 02:24 PM]