BETA

13th November 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/11/17 02:23 PM] with 'Partial Outage'

Issue has been resolved at [13/11/17 02:24 PM]