BETA

13th November 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [13/11/17 01:12 AM] with 'Major Outage'

Issue has been resolved at [13/11/17 01:13 AM]